Go to content Go to navigation Go to search

Redmine2.X でプラグインのrake時にSQLバージョンエラーが出た場合

11月 18th, 2012 by mattari

rake時に MySQL で以下のエラーが出た場合、

Incorrect MySQL client library version! This gem was compiled for 6.0.0 but the
client library is 5.5.28.

次の手順で回復します。

 

1. Redmine関係のサービスを停止する。
   BitNamiでのやり方は、<BITNAMI_ROOT>/manager-windows.exe を起動して、[Stop All] ボタンを押す。

2. MySQL Connector を以下のページから zip ファイルでダウンロードする。

http://www.mysql.com/downloads/connector/c/ 

3. zip を解凍した中の lib フォルダに libmysql.dll があるので、   

    これを<BITNAMI_ROOT>/ruby/bin フォルダの libmysql.dll 上書きコピーする。

4. <REDMINE_ROOT>/config/database.yml でmysql2となっていることを確認します。

    mysqlの場合は、mysql2 に修正します。

adapter: mysql2

5. Redmineを開始する。BitNamiの場合、manager-windows.exe で [Start All] ボタンを押す。
6. もう一度 rake をして、Redmineを再起動する。

 

« 前の記事

関連記事