Go to content Go to navigation Go to search

WordPress3.0 にアップデート、そして Fatal error

6月 24th, 2010 by mattari

WordPressダッシュボードに「WordPress 3.0 が利用可能です ! アップデートしてください。」と表示されるので自動更新してみました。
特に問題なく更新できましたが、デーマの変更をやったら、こんなエラーが出て admin ページすら表示できなくなりました。

Fatal error: require_once() [function.require]: Failed opening required ‘<WP-ROOT>/wp-includes/’ (include_path=’.;<hogehoge>’) in <WP-ROOT>\wp-config.php on line 84

なにやら wp-config.php の 84 行目がマズいそうです。

82: /** Sets up WordPress vars and included files. */
83: require_once(ABSPATH . ‘wp-settings.php’);
84: if(!function_exists(amt_cif)) { if(file_exists(ABSPATH.WPINC.’/’)) { require_once (ABSPATH.WPINC.’/’); } }

犯人探しも面倒なので、サクっと 84 行目を削除したら復活しました。

関連記事